If you use WordPress and your on version 2.11 you MUST upgrade as soon as possible. A hacker managed to insert a security exploit into the 2.11 files. Although this only happened in the last 3-4 days it makes sense to move to 2.12…NOW. The dev blog has all the details.

The 2.1 upgrade contained a lot of fixes and changes. One that I hated was the feeds no longer displayed full text if you used the ‘more’ tag. Bah. I hate feeds that are truncated or contain excerpts. Defeats the purpose of feeds in my opinion and…well…it just sucks. Thankfully there’s a plugin – where would we be without plugin authors filling the gaps?

Another plugin I’ve recently added is the Dunstan Style Error Page. This generates a far more helpful error page for those links that might no longer exist or typo’s on blogs elsewhere.

Searching in WordPress is fairly weak but the Search Everything plugin allows you to turn on searching for comments, pages, metadata and even attachments. Hopefully this will be added to WordPress core as it’s been an asked for feature for a long time.

Final new addition here is the DoFollow plugin. It’s not new but I installed it after reading Dougal Campbells post on why he had only just installed it. Made total sense so it’s here now too. Again this really should be an option in the core.

There’s been a lot of bashing of WordPress recently but I still think it’s a great platform with an active community around it. Contributers will come and go but hopefully a more active and aggressive release schedule will see some features being more frequently released.