Since I bought my Mac I have backed it up using SuperDuper! which was one of the recommended Mac backup applications. I’ve tested the backup to make sure I could boot from it but I’d never needed to use it in anger. Until today.

I had to reboot the iMac. It came up fine displaying the Apple logo and the spinner. Then the hard disk switched off and I was left looking at the logo and the spinner. That’s not right. Switched off and on and it was the same again. Feck. Another couple of goes and it was still the same. Time to reset PRAM. No difference. NVRAM? Still buggered. I booted from the Leopard DVD and ran a disk check. No issues. I ran a disk repair – no difference. I couldn’t figure out what was wrong. I did some surfing from the laptop and couldn’t really find any other step’s that would help. So it was time to finally use the SuperDuper! backup. It was time to restore!

I erased the disk and restored from the firewire drive. A couple of hours later I rebooted and I was back in business. Kind off. The backup was taken before the iPhone, iTunes and MobileMe updates and one they were on I synced with the iPhone…which wiped all the app’s from it. I had to download them, then install and set them up again. Annoying but nothing compared to the hassle and data loss had I not had that backup.

So thank you SuperDuper! for saving me tonight and hopefully this is a small lesson for anyone reading who doesn’t take regular backups. It also show’s that you should never assume a Mac is full proof. I just hope it was a one off glitch I experienced and it’s not a sign of impending hardware problems.